• 如果您觉得本站非常有看点,那么赶紧使用Ctrl+D 收藏吧

Eclipse 对 Java8 的支持

java 来源:Lesley dude 7次浏览

Eclipse Luna  SR2已经添加了对Java8的支持,可直接到官网下载
Luna。我这里有个 eclipse for mac的版本

如果你懒得下载Luna,并且已经有 Kepler SR2,可以通过下面三个步骤,添加对java8的支持。亲测成功 下述方法是在(Mac Yosemite + 英文版 Eclipse Kepler SR)的环境下进行的。


第一步:

1,打开Kepler SR2, Help -> Install New Software,打开Available Software对话框; 2,在Work with那里填入
http://download.eclipse.org/eclipse/updates/4.3-P-builds/
 

3,选中 Eclipse Java 8 Support(for Kepler SR2) 4,点 Next,Next,阅读并 Accept License, 点Finish 5,进度条走完以后,提示重启Eclipse。重启Eclipse后就可以使用编译Java 8的功能了。



第二步:(如果你已经安装了jdk8,并且添加到Eclipse里,可忽略这一步)

以上是Eclipse可以编译Java 8程序,但是同时,你也需要安装jdk8,下载安装好jdk8之后,在Eclipse Kepler中做如下步骤 Preference -> Java -> Installed JREs -> 添加 jdk1.8 (Add-> standard VM->Next -> 找到Java8 JRE的路径->Finish)

第三步 修改JDK Compliance,这样就可以支持java8的最新特性 Preference-> Java ->Compiler, JDK兼容性选择1.8,在KeplerSR2安装Java8 Support之前,这里JDK最高兼容1.7



完成以上三部,就可以编译一个Java 8 程序了

Java 8有很多优质的特性,例如lambda表达式,Optional等等,这里就不赘述了。 


版权声明:本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系管理员进行删除。
喜欢 (0)