• 如果您觉得本站非常有看点,那么赶紧使用Ctrl+D 收藏吧

我使用的是Deepin linux 15.4.1。我想安装Ruby语言,我想执行Sass/SCSS。但现在,我想这样做,因为root用户:

ruby 来源:snishalaka 6次浏览
gem install sass 

但是,我得到这个错误。我使用的是Deepin linux 15.4.1。我想安装Ruby语言,我想执行Sass/SCSS。但现在,我想这样做,因为root用户:

Fetching: rb-fsevent-0.10.2.gem (100%) 

成功安装RB-fsevent-0.10.2 撷取:FFI-1.9.18.gem(100%) 建筑机扩展。这可能需要一段时间… /usr/lib/ruby/2.3.0/rubygems/ext/builder.rb:76:警告:在PATH不安全的世界可写目录的/ opt,模式040777 错误:错误安装顶嘴: 错误:无法构建gem本机扩展。

current directory: /var/lib/gems/2.3.0/gems/ffi-1.9.18/ext/ffi_c 

/usr/bin/ruby2.3 -r ./siteconf20171018-24304-17ddhmp.rb extconf.rb mkmf.rb找不到头文件红宝石/ usr/lib中/红宝石/包括/ruby.h

extconf失败,退出代码1

宝石文件仍将安装在/var/lib/gems/2.3.0/gems/ffi-1.9.18进行检查。 记录到/var/lib/gems/2.3.0/extensions/x86_64-linux/2.3.0/ffi-1.9.18/gem_make.out的结果

这里有什么问题?我安装了Ruby的稳定版本2.4.2红宝石 Ruby stable release Ruby 2.4.2

===========解决方案如下:

这些类型的错误通常是系统的编译器错误在您的系统可能没有安装正确的核心C库。看看这个主题了解如何解决这个问题。

https://github.com/sass/sass/issues/2357

如何安装Ruby的? RVM,RBENV,在终端输入这个,给我们输出:

which ruby 
ruby -v 

而且你尝试运行sudo gem install sass

更新:您可能需要到创业板要安装的root访问权限。见warning: Insecure world writable dir /usr/local/bin in PATH, mode 040777

你也可以发布输出echo $PATH? 以及ruby -vwhich ruby如果没有这些,很难看到发生了什么。

我也建议你使用RVM来安装ruby。不知道你的linux版本是否预装了ruby版本,但你可以用RVM安装其他Ruby版本。


版权声明:本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系管理员进行删除。
喜欢 (0)