• 如果您觉得本站非常有看点,那么赶紧使用Ctrl+D 收藏吧

Rcpp包和预测包问题(旧版本)

r 来源:Aviad Klein 7次浏览

我有两个Linux机器R版本3.0.0Rcpp包和预测包问题(旧版本)

我已经在两台机器上安装了预测包版本4.8。

两台机器有依赖性的同一版本:

>ip <- installed.packages() 
>ip[c("forecast","Rcpp","RcppArmadillo"),c("Package","Version")] 
       Package   Version 
forecast  "forecast"  "4.8" 
Rcpp   "Rcpp"   "0.10.2" 
RcppArmadillo "RcppArmadillo" "0.4.000.4" 

但是,当我在其他节点我得到以下错误上运行它:

>library(forecast) 
Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) : 
    namespace ‘Rcpp’ 0.10.2 is already loaded, but >= 0.11.0 is required 
Error: package or namespace load failed for ‘forecast’ 

这些的R版本中是一个小老头,因为它们在Vertica的’R语言包’中使用,我无法升级版本和Rcpp包。

我怎样才能解决这个或进一步调查该问题?


===========解决方案如下:

也许您需要与Vertica交谈?

总之,做这些事情之一:

  • 去与你的供应商,并坚持旧的版本(这是坏,R 3.0.0已经由3.0.1和3.0.2取代下周有3.0.3出现; Rcpp 0.10.2是,现在我们在0.11.0);

  • 更新您的软件包,但要确保哟以锁步方式执行它(例如,使用您的预测版本生成时的当前Rcpp版本 – 当前您违反使用需要Rcpp 0.11.0的版本只有RCPP 0.10.2 [很老!];

  • 忽略你在当地的图书馆供应商和更新,预挂起的.libPaths()(见help(Startup)了解详细信息)

最后,如果我可能,我发现你的问题的标题有误导性。我想说错误是由于你安装了非m在您的基础R(来自Vertica)上进行修改。软件包Rcpp,RcppArmadillo和forecast在正常环境下都可以正常工作。


版权声明:本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系管理员进行删除。
喜欢 (0)