• 如果您觉得本站非常有看点,那么赶紧使用Ctrl+D 收藏吧

R在yaml依赖不会更新在Windows

r 来源:struggles 4次浏览

我在一台Windows机器上,我试图用RStudio编织一个RMarkdown文档。当我在RStudio中按’编织’按钮时,我得到一个“需要yaml包的更新版本”的消息。我在install.packages("yaml")找到一条消息,说的是“二进制源needs_compilation”。我查看了的CRAN页面,看起来Microsoft的二进制文件并不是最新的Mac版本(2.1.14 < 2.1.15)。我认为这是我无法编写RMarkdown文档的原因,但我不知道如何解决此问题。R在yaml依赖不会更新在Windows

这个错误在几天前弹出,我不知道如何解决它。我一直在编写文件,直到现在,并不知道该怎么做。

任何帮助或指导将不胜感激。

screenshot of me struggling with yaml

screenshot of me struggling with versions


===========解决方案如下:

@塞德里克的link帮助了。我不得不install()使用yamldevtools


版权声明:本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系管理员进行删除。
喜欢 (0)