• 如果您觉得本站非常有看点,那么赶紧使用Ctrl+D 收藏吧

SQLITE 3安装错误

python 来源:RockAndRoleCoder 5次浏览

我总是尝试通过命令行安装东西。我最近安装了Node(最新版本,版本号为9.20)。我正在尝试安装/设置GECKO进行汽车交易。它需要安装SQLite3。我正在关注的方向设置壁虎从这个链接:SQLITE 3安装错误

和我在一步就是,你在命令行中键入:NPM =安装

然而,它开始下载后,一些文件达到几个“ERR!”声明和切断。下面是输出:

(PS我也只用“故宫安装”,我已经使用“故宫安装sqlite3的”试过,都是给中端同样的错误尝试

C:\用户\ fable187 \下载\壁虎稳定\壁虎稳定> NPM安装sqlite3的

[email protected] install C:\Users\fable187\Downloads\gekko-stable\gekko-stable\node_modules\sqlite3 node-pre-gyp install –fallback-to-build

节点预GYP ERR试图下载(403):https://mapbox-node-binary.s3.amazonaws.com/sqlite3/v3.1.13/node-v59-win32-x64.tar.gz 节点预GYP ERR预建的二进制文件!找不到[email protected]和[email protected](node-v59 ABI)(回落到用node-gyp编译的源代码)

C:\ Users \ fable187 \ Downloads \ gekko-stable \ gekko-stable \ node_modules \ sqlite3>如果未定义npm_config_node_gyp(节点“C:\ Program Files \ nodejs \ node_modules \ npm \ bin \ node-gyp-bin \ …. \ node_modules \ node-gyp \ bin \ node-gyp.js“clean)else(node”“clean)

C:\ Users \ fable187 \ Downloads \ gekko-stable \ gekko-stable \ node_modules \ sqlite3>如果未定义npm_config_node_gyp(节点“C:\ Program Files \ nodejs \ node_modules \ npm \ bin \ node-gyp-bin \ …. \ node_modules \ node-gyp \ bin \ node-gyp.js”配置 – 下降到生成–module = C:\ Users \ fable187 \ Downloads \ gekko-stable \ gekko-stable \ node_modules \ sqlite3 \ lib \ binding \ node-v59-win32-x64 \ node_sqlite3.node –module_name = node_sqlite3 –module_path = C:\ Users \ fable187 \ Downloads \ gekko-stable \ gekko-stable \ node_modules \ sqlite3 \ lib \ binding \ node-v59-win32-x64 –msvs_version = 2017)else(node“”configure – fallback-to-build –module = C:\ Users \ fable187 \ Downloads \ gekko-stable \ gekko-stable \ node_modules \ sqlite3 \ lib \ binding \ node-v59-win32-x64 \ node_sqlite3.node –module_name = node_sqlite3 –module_path = C:\ Users \ fable187 \ Downloads \ gekko-stable \ gekko-stable \ node_modules \ sqlite3 \ lib \ binding \ node-v59-win32-x64 –msvs_version = 2017) gyp ERR!配置错误 gyp ERR!堆栈错误:找不到Python可执行文件“C:\ Users \ fable187 \ AppData \ Local \ Programs \ Python \ Python35 \ python.EXE”,您可以设置PYTHON env变量。 gyp ERR!在PythonFinder.failNoPython(C:\ Program Files \ nodejs \ node_modules \ npm \ node_modules \ node-gyp \ lib \ configure.js:483:19)上堆栈 gyp ERR!在PythonFinder中堆栈。 (C:\ Program Files \ nodejs \ node_modules \ npm \ node_modules \ node-gyp \ lib \ configure.js:508:16) gyp ERR!堆栈位于C:\ Program Files \ nodejs \ node_modules \ npm \ node_modules \ graceful-fs \ polyfills.js:284:29 gyp ERR!堆栈在FSReqWrap.oncomplete(fs.js:166:21) gyp ERR!系统Windows_NT 10.0.16299 gyp ERR!命令“C:\ Program Files \ nodejs \ node.exe”“C:\ Program Files \ nodejs \ node_modules \ npm \ node_modules \ node-gyp \ bin \ node-gyp.js”“configure”“–fallback-to “–module = C:\ Users \ fable187 \ Downloads \ gekko-stable \ gekko-stable \ node_modules \ sqlite3 \ lib \ binding \ node-v59-win32-x64 \ node_sqlite3.node”“–module_name = node_sqlite3“”–module_path = C:\ Users \ fable187 \ Downloads \ gekko-stable \ gekko-stable \ node_modules \ sqlite3 \ lib \ binding \ node-v59-win32-x64“”–msvs_version = 2017“ gyp ERR ! cwd C:\ Users \ fable187 \ Downloads \ gekko-stable \ gekko-stable \ node_modules \ sqlite3 gyp ERR! node -v v9.2.0 gyp ERR! node-gyp -v v3.6.2 gyp ERR!不好 node-pre-gyp ERR!生成错误 node-pre-gyp ERR!堆栈错误:无法执行’node-gyp.cmd configure – 下降生成–module = C:\ Users \ fable187 \ Downloads \ gekko-stable \ gekko-stable \ node_modules \ sqlite3 \ lib \ binding \ node -v59-win32-x64 \ node_sqlite3.node –module_name = node_sqlite3 –module_path = C:\ Users \ fable187 \ Downloads \ gekko-stable \ gekko-stable \ node_modules \ sqlite3 \ lib \ binding \ node-v59-win32- x64 –msvs_version = 2017’(1) node-pre-gyp ERR!堆栈在ChildProcess。 (C:\ Users \ fable187 \ Downloads \ gekko-stable \ gekko-stable \ node_modules \ sqlite3 \ node_modules \ node-pre-gyp \ lib \ util \ compile.js:83:29) node-pre-gyp ERR!堆栈在ChildProcess.emit(events.js:159:13) node-pre-gyp ERR! stack at maybeClose(internal/child_process.js:943:16) node-pre-gyp ERR!堆栈在Process.ChildProcess._handle.onexit(internal/child_process.js:220:5) node-pre-gyp ERR!系统Windows_NT 10.0.16299 node-pre-gyp ERR!命令“C:\ Program Files \ nodejs \ node.exe”“C:\ Users \ fable187 \ Downloads \ gekko-stable \ gekko-stable \ node_modules \ sqlite3 \ node_modules \ node-pre-gyp \ bin \ node-pre- gyp“”install“” – fallback-to-build“ node-pre-gyp ERR! cwd C:\ Users \ fable187 \ Downloads \ gekko-stable \ gekko-stable \ node_modules \ sqlite3 node-pre-gyp ERR! node -v v9.2.0 node-pre-gyp ERR! node-pre-gyp -v v0.6.38 node-pre-gyp ERR!不正确 未能执行’node-gyp.cmd configure – 下降到构建–module = C:\ Users \ fable187 \ Downloads \ gekko-stable \ gekko-stable \ node_modules \ sqlite3 \ lib \ binding \ node -v59-win32-x64 \ node_sqlite3.node –module_name = node_sqlite3 –module_path = C:\ Users \ fable187 \ Downloads \ gekko-stable \ gekko-stable \ node_modules \ sqlite3 \ lib \ binding \ node-v59-win32- x64 –msvs_version = 2017’(1) npm ERR!代码ELIFECYCLE npm ERR! errno 1 npm ERR! [email protected]安装:node-pre-gyp install --fallback-to-build npm ERR!退出状态1 npm ERR! npm ERR!在[email protected]安装脚本失败。 npm ERR!这可能不是npm的问题。上面可能还有其他日志记录输出。

npm ERR!此运行的完整日志可在以下位置找到: npm ERR! C:\ Users \用户fable187 \应用程序数据\漫游\ NPM-cache_logs \ 2017-12-03T08_00_31_371Z-的debug.log

C:\ Users \用户fable187 \下载\壁虎稳定\壁虎稳定>

===========解决方案如下:

SQLITE3尚未与NodeJS V9.2.0兼容(查看问题:https://github.com/mapbox/node-sqlite3/issues/902)。

您需要将您的nodeJS版本降级到V8.9.3。

提示:要伊斯利更改节点版本,你可以用NVM的Windows https://github.com/coreybutler/nvm-windows

Python的问题:这是由于“故宫安装”,这是试图编译(与Python)位于源节点-V59-Win32的x64.tar.gz。由于Python未在您的计算机上安装,因此出现错误。


版权声明:本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系管理员进行删除。
喜欢 (0)