• 如果您觉得本站非常有看点,那么赶紧使用Ctrl+D 收藏吧

标签:adt

adt

包含库jar时发生ClassNotFoundException

包含库jar时发生ClassNotFoundException
在我的android项目中,我在libs文件夹中添加了一个库jar。这个 jar 包含三个不同的包: 谷歌GSON(com.google.gson) jboss netty(org.jboss.netty) 我自己开发的客户端应用程序使用了另外两个库。 (com.example.core) 该jar使用ant进行编译/存档。 eclipse中没有错误,但……继续阅读 »

adt

管理切换按钮的状态

管理切换按钮的状态
我遇到的问题是管理切换按钮处于打开和关闭状态。该按钮打开/关闭蓝牙。我该如何做才能在不关闭应用程序的情况下轻松地打开和关闭按钮?现在,它仅在启动应用程序时有效。 if(!myBluetooth.isEnabled()){ final ToggleButton tglbtn = (ToggleButton)findViewById(R……继续阅读 »

adt

从Android服务调用AlertDialog.Builder

从Android服务调用AlertDialog.Builder
我想显示来自service的警报,我不在乎当前是什么活动,仅显示警报。 但是建设者需要像 AlertDialog.Builder builder = new AlertDialog.Builder(this); 但是我如何知道当前活动并传递给 AlertDialog.Builder? 解决方案如下: 但是我如何知道当前活动并传递给AlertDia……继续阅读 »

adt

无法从Eclipse,ADT 22.6创建或编辑Android虚拟设备(AVD)

无法从Eclipse,ADT 22.6创建或编辑Android虚拟设备(AVD)
这个问题听起来类似于few others,但是在我的情况下,“确定”按钮没有变灰。但是对于那些不想点击链接的人… 在输入设置后,尝试从Eclipse中创建或编辑AVD时,“确定”按钮似乎是“可单击的”,但是当我单击它时,绝对没有任何反应。 我确保已安装适当的系统镜像,并且目标平台与所使用的API匹配。显然,已经选择了CPU,设置了外观等等。所有会……继续阅读 »

adt

Android应用为空

Android应用为空
如果你们需要查看该代码,如果不是很明显,请告诉我,我在最后一个问题上显然张贴了waaaaay太多的代码。我一直在开发和运行eclipse的android应用,当运行时,在标题下方,我的应用为空。除了空白,我的控件/ UI均不可见。 Main.xml <?xml version="1.0" encoding="utf-8"?> <Scroll……继续阅读 »

adt

Android构建失败-java.lang.IllegalArgumentException:已添加:Lcom / google / api / client / escape / CharEscapers;

Android构建失败-java.lang.IllegalArgumentException:已添加:Lcom / google / api / client / escape / CharEscapers;
我只是为我的Android应用程序准备小更新,但是当我尝试构建我的应用程序时(在 Debug模式下),我得到了这个奇怪的错误。如果更聪明的人可以看一下以找出可能出了什么问题,那就太好了。我正在清理/重建/修复项目属性,但没有结果。我不知道这是怎么回事:(。也许有人在这里发生类似的事情?如果这可以帮助我,请使用以下库:adMob(4.1.1),openfein……继续阅读 »

adt

无法从Eclipse,ADT 22.6创建或编辑Android虚拟设备(AVD)

无法从Eclipse,ADT 22.6创建或编辑Android虚拟设备(AVD)
这个问题听起来类似于few others,但是在我的情况下,“确定”按钮没有变灰。但是对于那些不想点击链接的人… 在输入设置后,尝试从Eclipse中创建或编辑AVD时,“确定”按钮似乎是“可单击的”,但是当我单击它时,绝对没有任何反应。 我确保已安装适当的系统镜像,并且目标平台与所使用的API匹配。显然,已经选择了CPU,设置了外观等等。所有会……继续阅读 »

adt

使用Android开发工具23版更新Eclipse

使用Android开发工具23版更新Eclipse
我使用新的SDK工具(修订版23)更新了Eclipse,但是现在当Eclipse启动时,我收到以下错误消息: This Android SDK requires Android Developer Toolkit version 23.0.0 or above. Current version is 22.6.3.v201404151837-1123206……继续阅读 »

adt

使用Gradle,Android Studio,ADT构建依赖项

使用Gradle,Android Studio,ADT构建依赖项
我正在使用gradle项目开发Android应用程序。我的队友使用ADT,而我使用的是Android Studio,我想尽我所能,不要强行限制其他人使用IDE。 据我所知,ADT需要具有本地依赖项(.jar或本地lib)。另外,如果我有主项目和包含相同本地jar文件的本地库,则由于“IllegalArgumentException:已添加”而无法使用grad……继续阅读 »